<!DOCTYPE HTML><html lang="en-US" prefix="og: http://ogp.me/ns#">

<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind - Bellevue Business Journal</title>

<!-- This site is optimized with the Yoast SEO plugin v5.8 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind - Bellevue Business Journal" />
<meta property="og:description" content="The holiday season is just around the corner, which means it’s time to find the perfect gifts for your loved ones. But, what do you give to those who already have everything? Give them something you can’t buy in stores. Donate to Guide Dogs for the Blind (GDB) in their name. Not only will this &hellip;" />
<meta property="og:url" content="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" />
<meta property="og:site_name" content="Bellevue Business Journal" />
<meta property="article:tag" content="GDB" />
<meta property="article:tag" content="Guide Dogs for the Blind" />
<meta property="article:tag" content="Holiday Gift Guide" />
<meta property="article:section" content="Good Deeds" />
<meta property="article:published_time" content="2017-11-17T07:43:49-08:00" />
<meta property="og:image" content="http://bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide-300x198.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The holiday season is just around the corner, which means it’s time to find the perfect gifts for your loved ones. But, what do you give to those who already have everything? Give them something you can’t buy in stores. Donate to Guide Dogs for the Blind (GDB) in their name. Not only will this [&hellip;]" />
<meta name="twitter:title" content="What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind - Bellevue Business Journal" />
<meta name="twitter:image" content="http://bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide-300x198.png" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/bellevuebusinessjournal.com\/","name":"Bellevue Business Journal","potentialAction":{"@type":"SearchAction","target":"http:\/\/bellevuebusinessjournal.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/bellevuebusinessjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		

<!-- Stylesheets -->
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='formidable-css'  href='http://bellevuebusinessjournal.com/wp-content/uploads/formidable/css/formidablepro.css?ver=11131951' type='text/css' media='all' />
<link rel='stylesheet' id='headway-general-css'  href='http://bellevuebusinessjournal.com/wp-content/uploads/headway/cache/general-7d8b03b.css?ver=f133ee4f2ec9bc5e91304d7d52d12bf2' type='text/css' media='all' />
<link rel='stylesheet' id='headway-layout-index-css'  href='http://bellevuebusinessjournal.com/wp-content/uploads/headway/cache/layout-index-3b10d1c.css?ver=f133ee4f2ec9bc5e91304d7d52d12bf2' type='text/css' media='all' />
<link rel='stylesheet' id='headway-responsive-grid-css'  href='http://bellevuebusinessjournal.com/wp-content/uploads/headway/cache/responsive-grid-d2119e4.css?ver=f133ee4f2ec9bc5e91304d7d52d12bf2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.5' type='text/css' media='all' />


<!-- Scripts -->
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/themes/headway/library/media/js/jquery.fitvids.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/uploads/headway/cache/responsive-grid-js-e6e6939.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/themes/headway/library/blocks/navigation/js/selectnav.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/uploads/headway/cache/block-dynamic-js-layout-index-e3174e2.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>

<!--[if lt IE 9]>
<script src="http://bellevuebusinessjournal.com/wp-content/themes/headway/library/media/js/html5shiv.js"></script>
<![endif]-->

<!--[if lt IE 8]>
<script src="http://bellevuebusinessjournal.com/wp-content/themes/headway/library/media/js/ie8.js"></script>
<![endif]-->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-15084831-1', 'auto');
  ga('send', 'pageview');

</script>

<!-- Extras -->
<link rel="alternate" type="application/rss+xml" href="http://feeds.feedburner.com/bellevuenews" title="Bellevue Business Journal" />
<link rel="pingback" href="http://bellevuebusinessjournal.com/xmlrpc.php" />
	<meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0" />
<link rel="alternate" type="application/rss+xml" title="Bellevue Business Journal &raquo; Feed" href="http://feeds.feedburner.com/bellevuenews" />
<link rel="alternate" type="application/rss+xml" title="Bellevue Business Journal &raquo; Comments Feed" href="http://bellevuebusinessjournal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bellevue Business Journal &raquo; What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind Comments Feed" href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/feed/" />
<link rel='https://api.w.org/' href='http://bellevuebusinessjournal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://bellevuebusinessjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://bellevuebusinessjournal.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2CRRH-qS' />
<link rel="alternate" type="application/json+oembed" href="http://bellevuebusinessjournal.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbellevuebusinessjournal.com%2Fgood-deeds%2Fgive-already-holiday-season-guide-guide-dogs-blind%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://bellevuebusinessjournal.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbellevuebusinessjournal.com%2Fgood-deeds%2Fgive-already-holiday-season-guide-guide-dogs-blind%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//bellevuebusinessjournal.com/?wordfence_lh=1&hid=5D8CEDFB5EB4A48290717AACFD3BFF41');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
</head>

<body class="post-template-default single single-post postid-1666 single-format-standard custom responsive-grid-enabled responsive-grid-active layout-single-post-1666 layout-using-index" itemscope itemtype="http://schema.org/WebPage">


<div id="whitewrap">


<div id="wrapper-w4d56de2b5e3a46b" class="wrapper wrapper-fixed wrapper-fixed-grid grid-fluid-24-20-20 responsive-grid wrapper-last" data-alias="">

<div class="grid-container clearfix">

<section class="row row-1">

<section class="column column-1 grid-left-0 grid-width-24">
<header id="block-bb156de2b5e3bbd4" class="block block-type-header block-fixed-height" data-alias="" itemscope="" itemtype="http://schema.org/WPHeader">
<div class="block-content">
<a href="http://bellevuebusinessjournal.com" class="banner-image"><img src="http://bellevuebusinessjournal.com/wp-content/uploads/2017/04/bbj-banner3.gif" alt="Bellevue Business Journal" /></a>
</div>

</header>

</section>

</section>


<section class="row row-2">

<section class="column column-1 grid-left-0 grid-width-24">
<nav id="block-bql56de2b5e3ae8e" class="block block-type-navigation block-fluid-height" data-alias="" itemscope="" itemtype="http://schema.org/SiteNavigationElement">
<div class="block-content">
<div class="nav-horizontal nav-align-left"><ul id="menu-menu-1" class="menu"><li class="menu-item-home headway-home-link"><a href="http://bellevuebusinessjournal.com">Home</a></li><li id="menu-item-1486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1486"><a href="http://bellevuebusinessjournal.com/advertise/">Advertise</a></li>
<li id="menu-item-461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461"><a href="http://bellevuebusinessjournal.com/contact-bellevue-business-journal/">Contact</a></li>
<li id="menu-item-1488" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1488"><a href="http://bellevuebusinessjournal.com/bellevue-business-journal-partners/">Partners</a></li>
<li id="menu-item-1487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1487"><a href="http://bellevuebusinessjournal.com/submit-news-to-bellevue-business-journal/">Submit News</a></li>
</ul></div>
</div>

</nav>

</section>

</section>


<section class="row row-3">

<section class="column column-1 grid-left-0 grid-width-24">
<figure id="block-b8256de35e79ac84" class="block block-type-image block-fixed-height" data-alias="" itemscope="" itemtype="http://schema.org/ImageObject">
<div class="block-content">
<a href="https://virtuallyfamousmarketing.com" class="image" target="_blank"><img src="http://bellevuebusinessjournal.com/wp-content/uploads/2017/05/BBJ-Ad-Banner-940x140.gif" alt="Virtually Famous Marketing - We Make Your Business Famous Online" title="Virtually Famous Marketing - We Make Your Business Famous Online" itemprop="contentURL"/></a>
</div>

</figure>

</section>

</section>


<section class="row row-4">

<section class="column column-1 grid-left-0 grid-width-17">
<div id="block-b6t56de35e79b527" class="block block-type-content block-fluid-height" data-alias="">
<div class="block-content">
<div class="loop"><article id="post-1666" class="post-1666 post type-post status-publish format-standard hentry category-consumers category-good-deeds category-non-profits tag-gdb tag-guide-dogs-for-the-blind tag-holiday-gift-guide author-joe-kennedy " itemscope itemtype="http://schema.org/Article"><header><h1 class="entry-title" itemprop="headline">What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind</h1><div class="entry-meta entry-meta-above">Posted on <time class="entry-date published updated" itemprop="datePublished" datetime="2017-11-17T07:43:49+00:00">November 17, 2017</time> by <span class="entry-author vcard" itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="author-link fn nickname url" href="http://bellevuebusinessjournal.com/author/joe-kennedy/" title="View all posts by Joe Kennedy" itemprop="url"><span class="entry-author-name" itemprop="name">Joe Kennedy</span></a></span> &bull; <a href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/#respond" title="What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind &ndash; Comments" class="entry-comments">0 Comments</a></div></header><div class="entry-content" itemprop="text"><p><a href="https://i1.wp.com/bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide.png"><img class="alignright size-medium wp-image-1667" src="https://i1.wp.com/bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide.png?resize=300%2C198" alt="Guide Dogs for the Blind Holiday Gift Guide" srcset="https://i1.wp.com/bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide.png?resize=300%2C198 300w, https://i1.wp.com/bellevuebusinessjournal.com/wp-content/uploads/2017/11/Guide-Dogs-for-the-Blind-Holiday-Gift-Guide.png?w=626 626w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></a>The holiday season is just around the corner, which means it’s time to find the perfect gifts for your loved ones. But, what do you give to those who already have everything?</p>
<p>Give them something you can’t buy in stores. Donate to <a href="https://www.guidedogs.com/">Guide Dogs for the Blind </a>(GDB) in their name. Not only will this support these special furry friends, it will also allow GDB to continue to provide their services free of charge to people with blindness or visual impairments. Some important things to know about GDB:<span id="more-1666"></span></p>
<ul>
<li>GDB prepares highly-qualified guide dogs to serve and empower individuals who are blind or have low vision throughout North America.</li>
<li>GDB is recognized worldwide as a model for innovative training, unprecedented support of guide dog partnerships after graduation, and the success rate of its graduates via a world-class alumni association and veterinary financial assistance, as needed.</li>
<li>GDB receives no government funding and relies on the generosity of our donors.</li>
</ul>
<p>Shop a variety of donations below from skateboards for puppy socialization to naming a guide dog, ranging in price $50 &#8211; $5 million. For more information on GDB, visit <a href="http://guidedogs.com/">guidedogs.com</a>.</p>
<p><strong>$50: Skateboard Socialization </strong></p>
<p>These pups can&#8217;t wait to get their paws on a skateboard to help them adapt to different types of movement during their socialization. They may not be the next Tony Hawk, but their skateboard skills will get them one step closer to being an excellent guide when they grow up. : <a href="https://secure2.convio.net/gd/site/Ecommerce?VIEW_PRODUCT=true&amp;product_id=1126&amp;store_id=1681">$50/SKATEBOARD &#8211; ADD TO CART</a><strong> </strong></p>
<p><strong>$100: Special Delivery</strong></p>
<p>What could be better than a puppy at your door? This gift provides the transportation of one adorable puppy from GDB’s California campus to a volunteer puppy raiser, via puppy truck: <a href="https://secure2.convio.net/gd/site/Ecommerce?VIEW_PRODUCT=true&amp;product_id=1152&amp;store_id=1681">$100/TRANSPORTATION FOR ONE PUP &#8211; ADD TO CART</a></p>
<p><strong>$1,000: </strong><strong>Happy Campers!</strong></p>
<p>Camp GDB brings together youth who are blind or visually impaired at our campuses to learn about the guide dog lifestyle, including what it is like to travel and live with aguide dog. It is four days of adventure, fun, and learning … with four-legged canine pals in on the action. <a href="https://secure2.convio.net/gd/site/Ecommerce?VIEW_PRODUCT=true&amp;product_id=1171&amp;store_id=1681">$1,000/CAMP GDB-ADD TO CART</a></p>
<p><strong>$5,000: Say My Name, Say My Name</strong></p>
<p>This gift helps to cover the costs for a guide dog puppy-in-training and provides an honor reserved for special members of the Guide Dogs for the Blind family — the opportunity to give a puppy his/her name for life. <a href="https://secure2.convio.net/gd/site/Ecommerce?VIEW_PRODUCT=true&amp;product_id=1176&amp;store_id=1681">$5,000 THE FOREVER FRIEND-ADD TO CART</a><strong> </strong></p>
<p><strong>$5 million: Centered on Puppies</strong></p>
<p>This generous gift affords an individual or a company an opportunity to name the new Guide Dogs for the Blind Puppy Center. Puppies will begin their journey to becoming guide dogs at the new state-of-the-art 28,000-square foot facility complete with a puppy nursery; an innovative “Young Heroes Academy” where the puppies learn to socialize with humans and one another; and The Learning Lab, a public education center, where visitors can view the puppies at work. (contact Therese Jacobson via tjacobson@guidedogs.com)</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" data-text="What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind" data-via="BellevueNews" >Tweet</a></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/"></div></div></li><li class="share-facebook"><div class="fb-share-button" data-href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" data-layout="button_count"></div></li><li class="share-tumblr"><a target="_blank" href="https://www.tumblr.com/share/link/?url=http%3A%2F%2Fbellevuebusinessjournal.com%2Fgood-deeds%2Fgive-already-holiday-season-guide-guide-dogs-blind%2F&name=What%20to%20Give%20Those%20that%20Already%20Have%20it%20All%20This%20Holiday%20Season%3A%20A%20Guide%20from%20Guide%20Dogs%20for%20the%20Blind" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('https://platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fbellevuebusinessjournal.com%2Fgood-deeds%2Fgive-already-holiday-season-guide-guide-dogs-blind%2F&#038;media=http%3A%2F%2F2.gravatar.com%2Favatar%2F50f37f9bf223b7014456bc0c2029fa6b%3Fs%3D96%26d%3Dmm%26r%3Dg&#038;description=What%20to%20Give%20Those%20that%20Already%20Have%20it%20All%20This%20Holiday%20Season%3A%20A%20Guide%20from%20Guide%20Dogs%20for%20the%20Blind" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" data-recalc-dims="1" /></a></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" data-counter="right"></script></div></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-skype"><div class="skype-share" data-href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/" data-lang="en-US" data-style="small" data-source="jetpack" ></div></li><li class="share-reddit"><div class="reddit_button"><iframe src="http://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=http%3A%2F%2Fbellevuebusinessjournal.com%2Fgood-deeds%2Fgive-already-holiday-season-guide-guide-dogs-blind%2F&amp;title=What%20to%20Give%20Those%20that%20Already%20Have%20it%20All%20This%20Holiday%20Season%3A%20A%20Guide%20from%20Guide%20Dogs%20for%20the%20Blind" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div><footer class="entry-utility entry-utility-below entry-meta">Filed Under: <a href="http://bellevuebusinessjournal.com/category/consumers/" rel="category tag">Consumers</a>, <a href="http://bellevuebusinessjournal.com/category/good-deeds/" rel="category tag">Good Deeds</a>, <a href="http://bellevuebusinessjournal.com/category/non-profits/" rel="category tag">Non-Profits</a></footer></article><div id="nav-below" class="loop-navigation single-post-navigation loop-utility loop-utility-below" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="nav-previous" itemprop="url"><a href="http://bellevuebusinessjournal.com/events/bellevue-magic-season-ice-arena-offers-free-admission-library-appreciation-day/" rel="prev"><span class="meta-nav">&larr;</span> Bellevue Magic Season Ice Arena Offers Free Admission on “Library Appreciation Day”</a></div><div class="nav-next" itemprop="url"></div></div><div id="comments">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://bellevuebusinessjournal.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1666' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8332c1f716" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="134"/></p>			</form>
			</div><!-- #respond -->
	</div></div>
</div>

</div>

<section class="sub-column sub-column-1 column column-1 grid-width-12 grid-left-0">
<footer id="block-b8g56de2b5e3bfa3" class="block block-type-footer block-fluid-height" data-alias="" itemscope="" itemtype="http://schema.org/WPFooter">
<div class="block-content">

<div class="footer-container">

<div class="footer">
<a href="#" class="footer-right footer-go-to-top-link footer-link">Go To Top</a><p class="copyright footer-copyright">Copyright © 2017 BellevueBusinessJournal.com and Virtually Famous Marketing</p><p class="footer-responsive-grid-link-container footer-responsive-grid-link-disable-container"><a href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/?full-site=true" rel="nofollow" class="footer-responsive-grid-link footer-responsive-grid-disable footer-link">View Full Site</a></p>
</div>
</div>
</div>

</footer>

</section>

</section>

<section class="column column-2 grid-left-0 grid-width-7">
<aside id="block-bfh56de2b5e3c305" class="block block-type-widget-area block-fluid-height" data-alias="" itemscope="" itemtype="http://schema.org/WPSideBar">
<div class="block-content">
<ul class="widget-area"><li id="search-2" class="widget widget_search">

		<form method="get" id="searchform" action="http://bellevuebusinessjournal.com/">
			<label for="s" class="assistive-text">Search</label>
			<input type="text" class="field" name="s" id="s" value="Type to search, then press enter" onclick="if(this.value=='Type to search, then press enter')this.value='';" onblur="if(this.value=='')this.value='Type to search, then press enter';" />
			<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
		</form>
	</li>
<li id="text-8" class="widget widget_text">
			<div class="textwidget"><a href="http://www.pjtra.com/t/SkNITUtOR0dDR0ZPSkhJQ0dLSUdOSw"><img src="http://www.pjtra.com/b/SkNITUtOR0dDR0ZPSkhJQ0dLSUdOSw" border="0" width="250" height="250" title="Free Shipping on Orders over $35" alt="Free Shipping on Orders over $35"></a></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html">
<div class="textwidget custom-html-widget"><a href="//www.bluehost.com/track/joeconnector/BBJ" target="_blank"> <img border="0" src="https://i2.wp.com/bluehost-cdn.com/media/partner/images/joeconnector/300x250/300x250BW.png" data-recalc-dims="1"> </a></div></li>
		<li id="recent-posts-2" class="widget widget_recent_entries">
		<h3 class="widget-title"><span class="widget-inner">Recent Posts</span></h3>
		<ul>
											<li>
					<a href="http://bellevuebusinessjournal.com/good-deeds/give-already-holiday-season-guide-guide-dogs-blind/">What to Give Those that Already Have it All This Holiday Season: A Guide from Guide Dogs for the Blind</a>
									</li>
											<li>
					<a href="http://bellevuebusinessjournal.com/events/bellevue-magic-season-ice-arena-offers-free-admission-library-appreciation-day/">Bellevue Magic Season Ice Arena Offers Free Admission on “Library Appreciation Day”</a>
									</li>
											<li>
					<a href="http://bellevuebusinessjournal.com/healthcare/overlake-medical-center-invites-public-open-house-new-sammamish-clinic/">Overlake Medical Center Invites Public to Open House at New Sammamish Clinic Saturday November 18</a>
									</li>
											<li>
					<a href="http://bellevuebusinessjournal.com/uncategorized/lineage-2-revolutions-live-announcement-twitchcon-2017-special-guestconan-obrien-fans-eager-launch-date/">Lineage 2: Revolution’s Live Announcement During TwitchCon 2017 With Special GuestConan O’Brien Has Fans Eager For Its Launch Date</a>
									</li>
											<li>
					<a href="http://bellevuebusinessjournal.com/non-profits/americas-car-museum-exhibit-showcase-century-american-culture/">America’s Car Museum Exhibit to Showcase a Century of American Culture</a>
									</li>
					</ul>
		</li>
<li id="text-2" class="widget widget_text">
			<div class="textwidget"><div class="AW-Form-1991858149"></div>
<script type="text/javascript">(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//forms.aweber.com/form/49/1991858149.js";
    fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "aweber-wjs-frh6z0nw8"));
</script></div>
		</li>
<li id="text-3" class="widget widget_text">
			<div class="textwidget"><a href="http://www.pjtra.com/t/SkNITkhKR0ZDR0ZPSkhJQ0dLSElJRw"><img src="http://www.pjtra.com/b/SkNITkhKR0ZDR0ZPSkhJQ0dLSElJRw" border="0" width="250" height="250" title="SNUZ Pillow- Put some spring back in your step!" alt="SNUZ Pillow- Put some spring back in your step!"></a></div>
		</li>
</ul>
</div>

</aside>

</section>

</section>


<section class="row row-5">

<section class="column column-1 grid-left-12 grid-width-12">
<div id="block-biu56e87acc26fdd" class="block block-type-custom-code block-fluid-height" data-alias="">
<div class="block-content">
<a href="http://stacialoo.socialpaid.hop.clickbank.net"><img src="https://s3.amazonaws.com/Clicktrix/affiliates/promotion_tools/banners/paidsocialmediajobs/static/468x60.jpg" /></a>
</div>

</div>

</section>

</section>


</div>

</div>



	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/bellevuebusinessjournal.com\/good-deeds\/give-already-holiday-season-guide-guide-dogs-blind\/":1666};
	</script>
			<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.min.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
			<script type="text/javascript" src="https://platform.tumblr.com/v1/share.js"></script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>		<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
				<script>
		(function(r, d, s) {
			r.loadSkypeWebSdkAsync = r.loadSkypeWebSdkAsync || function(p) {
				var js, sjs = d.getElementsByTagName(s)[0];
				if (d.getElementById(p.id)) { return; }
				js = d.createElement(s);
				js.id = p.id;
				js.src = p.scriptToLoad;
				js.onload = p.callback
				sjs.parentNode.insertBefore(js, sjs);
			};
			var p = {
				scriptToLoad: 'https://swx.cdn.skype.com/shared/v/latest/skypewebsdk.js',
				id: 'skype_web_sdk'
			};
			r.loadSkypeWebSdkAsync(p);
		})(window, document, 'script');
		</script>
		<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-includes/js/comment-reply.min.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201746'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-includes/js/wp-embed.min.js?ver=f133ee4f2ec9bc5e91304d7d52d12bf2'></script>
<script async="async" type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bellevuebusinessjournal.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.5'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201746.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.5',blog:'38816197',post:'1666',tz:'-8',srv:'bellevuebusinessjournal.com'} ]);
	_stq.push([ 'clickTrackerInit', '38816197', '1666' ]);
</script>


</div>



</body>


</html>